eStatements

eApply

Online Banking Change

Monday, April 09, 2018

RSNB Bank has your best interest when it comes to Online Banking and security. Effective May 7th, Transport Layer Security (TLS) 1.0 and 1.1 will be disabled for Personal and Business Online Banking in order to maintain the highest standard of security. TLS 1.2 must be enabled in order to continue use of Online Banking. If you are using a current, up-to-date browser, TLS 1.2 is enabled by default. If you are using an older browser version, TLS 1.2 is not enabled by default or not compatible. Below is a basic TLS 1.2 compatibility chart. If you have any questions, please contact Online Banking Support at 307.362.4802.

Browser TLS 1.2 Compatibility
Microsoft Edge Compatible by default
Microsoft Internet Explorer 11 Compatible by default
Microsoft Internet Explorer 9 and 10 Compatible with Window 7, but not enabled by default
Firefox 27 and higher Compatible by default
Google Chrome 38 and higher Compatible by default
Apple Safari 7 or greater Compatible by default